ワイヴァンアイエス研究所ブログ

ストレージシステムやITの技術動向やテクノロジーなどを紹介。その他、趣味的な話題もあります
ワイヴァンアイエス研究所ブログ TOP  >  Homebuild computer >  ネットワークポートのチーミング(つづき)

ネットワークポートのチーミング(つづき)

 2017.06.30にアップした記事「ネットワークポートのチーミング」で課題が一つ残っていました。それはPCを再起動するとチーミングAdaptive Load Balancingの設定が保持されないことでした(以下)。

『チーミングを構成する一方のアダプタのステータスが「非アクティブ」になってしまいます(Team0のプロパティ → [設定]タブでチェックする)』

 時間がかかりましたがようやく問題が解決しました。解決に至る経緯は長くなりますので、最後にします。

 デバイスマネージャーからネットワークアダプターのTeam0プロパティを表示させます。
さらに「詳細設定」タブ → 「プローブ」項目 → 「プロパティー(P)」とたどります。
 Team0_Property3.png 

 Team0_Property3-1.png 
 ここの箇所にあるプローブの説明には

『チーム用にプローブを使用できるようにします。プローブは、チームのメンバー間のネットワーク経由で渡し、Advanced Network Services (ANS) Teaming ソフトウェアがメンバーの状態をテストできるようにするパケットです。これらはネットワークに多少トラフィックを追加することになるので、容量に余裕のないネットワークではオフにしてください』

とあります。起動時にはネットワーク容量に余裕がなくなるのでしょうか。上部にある「プローブを送信する(S)」のチェックを外します。
 Team0_Property3-2.png

 この後にPCを再起動してチーミング状態を確認してみました。問題は起こっていません!! 両方のアダプターは「アクティブ」となっていて、アダプティブロードバランシング機能を開始しています。=解決です=

 以下は、どのような経緯で上記の解決にたどり着いたかの説明になります。ご興味があればお読みください。

 イベントビューアーに何か問題が記録されていないかを調べましたが、レベルが「エラー」のイベントにそれらしいログはありません。しかし、「警告」レベルのイベントにヒントになりそうな以下のログがありました。

  • ID 11 次のアダプター リンクは接続されていません: Intel(R) Gigabit CT Desktop Adapter
  • ID 11 次のアダプター リンクは接続されていません: Intel(R) Ethernet Connection I217-V
  • ID 13 Intel(R) Gigabit CT Desktop Adapter がチームで無効化されました
  • ID 16 チーム #1: 最後のアダプターはリンクを失いました。チームのネットワークの接続が失われました
  • ID 27 Intel(R) Gigabit CT Desktop Adapter Network link is disconnected

 そこで、それぞれのアダプターのプロパティで詳細設定の「リンク」項目の値を変更してみました(デバイスマネージャーのネットワークアダプターを展開してアダプターを表示し以下の値を変えました)。

 Intel Ethernet Connection I217-V
  詳細設定 → リンクを待機 → 値:「自動検出」 → 「オン」

 Intel Gigabit CT Desktop Adapter
  詳細設定 → Wait for Link → 値:「Auto Detect」 → 「On」

 この変更を行ってPCを再起動して確認しましたが、問題は解決しませんでした。やはり両方のアダプターが「アクティブ」になりません。まだ片方のアダプターI217-Vが「非アクティブ」の状態で起動してしまっています。効果がないようなので、上記の「リンク」と「Wait for Link」の設定を元に戻しました。

 ここでイベントビューアーを見ると、上記の「警告」(ID 11、13、16、27)に加えて新たなログが記録されていました。

  • ID 22 プライマリー・アダプターは次のプローブを検出しませんでした。: Intel(R) Ethernet Connection I217-V  原因: チームが分割されている可能性があります

 この「プローブ」に関することが原因かどうかは確信が持てませんでしたので、他の可能性も同時に調べていきましたが、あるとき某メーカーのサーバーのテクニカルガイドには「2ポート構成でプローブ機能は不要」、他メーカーのサーバーのマニュアルには「『ID 22 プローブを検出しませんでした』の警告が出たら、プローブ機能をオフにする」という記述を見つけました。しかしながら具体的に、どの箇所の項目を変えれば良いか、という記述はありませんでした。そのため、Team0のプロパティの「詳細設定」のなかに、「プローブ」項目を発見するまで時間がかかりました。

 今回のトラブルシューティングの過程で、「リンク」項目を「オン」(「Wait for Link」項目を「On」)にしたことは、直接の問題解決にはなりませんでしたが、ID 22の警告が吐き出されたことで隠れていた本質的な原因が浮き出てきた結果となりました。

 他の記事も含めてですが、文章にしてしまうと簡単にスムーズに問題を解決したように見えますね。でも、実際は。。。



ランキングに参加しています。
↓以下のバナーをクリックしていただくと、とても励みになります!
にほんブログ村 IT技術ブログ IT技術情報へ
[ 2017年07月06日 21:10 ] カテゴリ:Homebuild computer | TB(0) | CM(0)
コメントの投稿












管理者にだけ表示を許可する
トラックバック
この記事のトラックバックURL